Sunday, November 11, 2007

Firmware poll

I'm interested in which firmware everyone is running on. It would be very helpful if you could reply to this post with a) which model of PSP you're using ('fat'/slim, revision # if known) and b) which firmware you're using.

I have two PSPs. I have an original Japanese PSP with v1.00 firmware which I use for development, and a UK PSP which usually runs the latest official firmware (v3.72 at the moment.)

I'm interested because I want to know if anyone still requires the v1.50 (kxploit) versions of Daedalus that I release. I also need to figure out if it's worth my time getting a slim PSP for developing with the v3.xx+ firmware.

Thanks!
-StrmnNrmn

125 comments:

Macia said...

I'm using PSP 1004 FAT with 3.71m33-3 + 1.5-2

nicholas said...

im using a PSP 1003 FAT with 3.71m33-3 + 1.5-2 aswell but i use the daedalus for 1.00 psp's because i am getting a slim/lite for christmas

go on please get the slim because now dark alex has released the programe so u can use the extra memory for programmes

Swish said...

I have PSP 1002 fat with firmware 3.52 M33-3

The download count for each version of Daedalus R13 at QJ.NET is:

Daedalus R13 for 1.00
Downloads 2,917 times

Daedalus R13 for 1.50
Downloads 13,006 times

StrmnNrmn said...

swish: Thanks for pointing out the download count- that's very useful. Sourceforge has a download count too - for R11/12/13 combined:

v1.00: 12,771
v1.50: 74,190

So it seems that v1.50 is still very popular.

Can you guys run both v1.00 and v1.50 firmware homebrew on 3.52/3.71 custom firmwares?

Boaz said...

1.50 is more used becouse almost everyone is on custom firmware that i think dont runs 1.00 homebrew.

I am on firmware 3.72HX-1 with 1.50 addon.
Its almost desame thing as 3.71.
Its a fat psp...

Samuel said...

I'm using

a) PSP Fat (don't know the revision

b) with 3.71M33-2

Swish said...

@StrmnNrmn

I tried out Daedalus R13 for 1.00 on my custom firmware and it worked.

Checkviller said...

two psp's:

PSP fat (PSP-1004)
3.71 M33-3 (using 1.5 eboots, dunno if the 1.00 works on it... haven't tried it yet)

PSP Slim (PSP-2004 IS)
3.71 M33-3 (using the 1.00 eboot)

both my psp's are european ones.

Dan4o2 said...

I'm on 3.71 M33-3 + 1.50 add-on 2.

Since first custom firmwares (even only 1.50 ones), anyone can use the 1.00 version (why bother having 2 folders when you can have only one ?) with a 1.50 kernel.

More and more people should use a custom firmware nowadays since they are more convenient (homebrews running on 1.50 or 2.71/3.XX kernel + commercial games running on 2.71/3.XX kernel).

As it works in 3.XX kernel, I load Daedalus in 3.XX kernel.

Yoshi Party said...

PSP 1004
3.52M33-4

filiph said...

I use a psp fattie, with 3,71 m33-3 + 1.50 kernel v2 and i use the 1.00's but i have tested with the 1.50's and it works great, but i prefer non kxploited... i think most ppl think that they need the 1.50 vers hence to the 1.50 kernel, but thats not the case on most CFW's

GmDude66 said...

Strmnnrmn: We can use 1.00, 1.50, or 3.xx on our custom firmwares, I don't know why but I always just choose 1.50 :P

My PSP:
1001 Fat (US)
TA-079
3.71 M33-3 + 1.5 add-on v2

Ole Fossbakk said...

I have a PSP 1004 with 3.71 M33-2 + 1.50 kernel addon v2 (which is needed to run 1.00/1.50 homebrew). I'll update to M33-3 soon, but both run Daedalus R13 using the 1.00 EBOOT perfectly.

I think people think custom firmware can't run 1.00 homebrew, because there is no benefit with 1.50. 1.00 is both faster to load (if you use "hide corrupted icons" in recovery mode) and is only folder, so it's more tidy. As if that wasn't enough, Slim PSPs seem to be able to run the 1.00 version. I doubt many people would miss a 1.50 kernel version. Besides, is there any problem with converting Daedalus EBOOTS to 1.50 from a 1.00 version using one of the many converters?

StrmnNrmn said...

filiph: I think you're right, I think people go for the v1.50 because it's the bigger of the two numbers.

I think I'd be better off renaming my v1.50+ release as 'kxploit for v1.50' and the v1.00 as 'everything else'.

Adam said...

I have a launch model PSP with 3.52 M33-4 and I've been using the 1.00 eboots. People probably still use the 1.50 eboots because thats what they're used to and they don't realize that custom firmware can launch 1.00 eboots.

AgentSmith said...

Well - I am currrently using custom firm 3.71 m33-3 with the 1.50-2 kernel add-on. My psp is a fat model # psp1001 US version. I hope this can help the cause in some fashion and good luck getting the ME engine implementations working. Thank Stormin' Norman, this is awesome!

Adam said...

Yeah, almost everyone has custom firmware, but most people who have it seem to think they need the 1.5 version of everything. Probably because all the guides say to make a folder called GAME150, and people don't know that you can run 1.0 homebrew from the 150 folder. I have 3.52 m33-4.

Martin said...

PSP 1004 with 3.71m33-3 (1.5-2) here :)

Josh said...

PSP 1001 with 3.71m33-3 (1.5-2)

Haven't used the kxploited eboots in a long long time.

XG917 said...

I have a Fat PSP TA-082 v2
Firmware: 3.52 M33-4
i use the 1.00 Eboot of daedalus and it works perfect. all custom firmwares can use 1.00 version of eboot. i also find it convenient because it only uses one folder (does not need a % folder, as you already know)

i heard that using 3.XX kernel would allow homebrew to use SOME extra ram. i am not sure though

zacharya1990 said...

Phat 1001 TA-097 running 3.52m33-4 using the 1.0 Eboot for R13

Cut-Up Radio said...

I'm using 3.71 M33-3. Even though i could use the 1.00 eboot i tend to always use the 1.50 eboot because a lot of homebrew is still released just on 1.50 eboot so i like to keep everything like that for organization. I don't know of sure but i think some people still download 1.50 eboots on custom firmware.

Morgan said...

PSP1000 and 3.71 M33-3

the_eternal_dark said...

PSP fat running 3.52M33-4 running a combo of 1.0 and 1.5 (currently running the 1.0 version R13).

brunobelo said...

I'm using 3.40 OE-A and I think I'll be using it for a long time...

t3heford said...

fat 1001 3.71m33-3+1.5-2
slim 2001 3.71m33-3

You should definitely get a slim strmnnrmn, they're brighter and so much more comfortable to hold!

s said...

Using the download comments on sourceforge and etc is not a good indicator of the distribution of hardware, this is primarily because it is cummulative and include the time before the slim was released. Also both versions of daedalus run on all CFW's so that makes the count completely irrelivant, moreover as much as i dislike the idea of forcing someone to update to new firmware (no one wants to sink to sony's level) the new CFW's are completely stable (except maybe the hx as generaly whenever you reverse engineer something there are flaws, and he admits to not being able to re some things.) so unless you're on 1.00 you really should upgrade (actually even on 1.00 you can still revert back to it via pandora so there's no chance of undesired effects.

Regardless here are my specs:
PSP-2001:
(Slim, daxter pack, on release date) running 3.71 M33-3
PSP-1002B:
running 3.52 M33-4 (sold it to someone in this state so someone has one).

Ben said...

3.52 M33 on PSP-1001 (fat)

Both 1.00 and 1.50 eboots work on custom firmwares. I prefer to use 1.00 eboots because having one folder is more organized.

GoGo Yubari said...

I have a Fat JAP PSP White, it's original FW is 2.0. The current FW is 3.40 OE-A.

Karl said...

I have a PSP 1002 fat with 3.40 OE-A.

Mattias said...

i have a fat psp 1000 something.

3.10 OE-A

thanx strmn :)

Luciano Braga said...

PSP-1001, FAT, 3.52 M33-4 .

Luciano Braga said...
This comment has been removed by the author.
Matthew said...

I'm using a PSP-1003 (UK/EU) with v3.71 M33 firmware.

A v3.xx firmware release would be useful for people on custom firmware without v1.50 kernel patch installed, not just for the PSP Slim & Lite.

keyrune said...

3.71 M33-3

René said...

I have
PSP 1003 Fat (US)
Firmware: 3.71 M33-3

Oliver said...
This comment has been removed by the author.
Oliver said...

3.71 M33-3 and I use Daedalus for 1.50. Keep up the great work strmnnrmn, your program is literally the reason I bought a PSP!

Peter said...

Original North American release fat PSP

Running PSP firmware 3.71M33-3

Thanks for all of your hard work on this emulator! It's amazing!

Antonio said...

PSP FAT 1004 with 3.40 OE-A

Congratulations for your work!!

jo said...

I have a PSP Slim 2001 3.71 m33 -2
and the 1.00 eboot works perfectly.Wish Starfox 64 was working but otherwise all my other roms are working great (Super Mario 64 and Super Smash Bros).

wally said...

Hi Strmnnrmn,

I have a PSP 1002K w/ 3.71 M33-3

and a PSP 2000k (Slim) w/ 3.71 M33-3

The slim is nice, but you need to *cough* up the money :P

john said...

i have-

PSP 1001(fat) 3.71 M33-3(1.50 kernel)

PSp 2001(slim) 3.71 M33-3

i use both 1.50 and 1.00 eboots.

Jesse said...

a) PSP FAT
b) v1.50

Rodrigo Cardoso said...

PSP-1000 (FAT)
Its the US Launch pack (that with spiderman 2 and a demo disk free)

running Daedalus R13 for 1.00 firmware in a 3.52 M33-3 Custom Firmware

both 1.0 and 1.5 eboots works here, but i prefer the 1.0 one (no corrupted things in XMB)

jo said...

Besides the folders , what is the difference between 1.50 Daedalus and 1.00 Daedalus.Is it the code altogether or just the folders ? Another question but off subject ; is there an "Age of Empires" game on the N64 because i really wanna play it on my PSP.If there is please tell me where to download it.If not i will try to learn c++ and port it to the PSP.

Samuel said...

PSP 1000 Self imported from Akihabara
Firmware 3.10 OE

Witold said...

PSP Slim & Lite - 2004.
Firmware revision: 3.71 m33-3.

Of course Daedalus 1.00, as 1.50 is a big no-go for slim.

cya
Raziel-chan

Jody said...

I use 3.52 M33-4. I tried 3.71 M33-3 + 1.5-2 and it really sucks. Lots of PRXs don't work anymore. I don't think anyone has 1.5 anymore.

Michael said...

i have PSP 1004 FAT with 3.40 oe-A

Josep said...

I have a 3.71M33-3 with 1.5v2, in a PSP 1004 (FAT). I must admit that it will be very interesting to make a version of the emulator for PSP Slim, given that you'll have 32 more Mb of RAM to use, but please, don't forget us (it's a more interesting challenge to make it work properly with just 32Mb of RAM)! I also want to thank you for the work you are doing, StrmnNrmn. Thank You. CU

Tyler said...

Im using a psp slim with the latest custom firmware, and a fatass with 3.52 M33.

T_K_15 said...

I'm running a PSP Phat (don't know model number) with M33 3.71-2 and 1.5 Kernel-2.

MFuni-X said...

I'm using 2 PSPs

PSP Fat CFW 3.71 M33-3 with 1.50 Kernel add on

PSP Slim CFW 3.71 M33-3

Good Luck and Be Happy

Nekoakuma said...

PSP-1002 FAT 3.71m33-2 + 1.5^2

Usually use kxploited things in all homebrew (just because it's what i'm more used to.)

Original Lemon Tang said...

For me psp fat, 3.40 OE-A with 1.50 enabled

Eric said...
This comment has been removed by the author.
Eric said...

Hello, i'am MaGiXieN webmaster of PSP-Generation (pspgen.com). *


Just for help, we have done deux poll recently:

- Which firmware have you in your PSP ?

3.71M33 - 56.42% (6473)
3.52M33 - 8.45% (2117)
3.40OE - 8.60% (987)
1.50 - 0.81% (93)
Another custom firmware - 1.89% (217)
3.71 - 7.86% (902)
3.xx except 3.71 - 4.23% (485)
2.xx - 0.85% (98)
1.xx - 0.88% (101)



- Have you buy a PSP "Slim & Lite"?

Yes, this is my first PSP - 11.02% (846)
Yes but I keep my "fat" - 9.25% (710)
Yes but I had sell my "fat" - 7.35% (564)
No, I keep my "fat" - 56.55% (4340)
No, one day perhaps. - 15.83% (1215)


It can be help you to have an overview of that french speakink people have.

Michael said...

PSP Slim 3.71m33

Kelde said...

PSP FAT 3.71M33-3 + 1.5v2

Soop said...

PSP fat 1001 (I think - 1st batch of Japanese Ceramic White PSPs) 3.71m33

walar said...

I have PSP2004 slim with firmware 3.71 M33-3

bsk said...

PSP 1004 (FAT)
3.71 M33-3

bsk said...

PSP 1004 (FAT)
FW : 3.71 M33-3

bsk said...

PSP 1004 (FAT)
FW : 3.71 M33-3

titdav_14 said...

I'm using (me and two freinds)

a) three PSP Fat

b) with 3.71M33 installed

Rafa said...

Im using psp slim 3.71 M33-3. I think that you can do a special version for psp slim because now in 3.71 M33-3 you can use extra memory.

Thanks a lot. Greetings.

Mikote2000 from Spain

Ximarx said...

Psp Slim 2004
FW: 3.71 m33-3

groovebox said...

I'm using a PSP 2001 Slim with 3.71M33-3.

charles0292 said...

I have a psp 1003 fat firmware 3.52 M33-3 and i use the deadalus for 1.50 psp's

Francis said...

fat psp 1001
3.71 M33

brponter said...

I've got a FAT with CFW 3.71 m33-2 and 1.5-2.

I'd like to tell you the revision, but I don't think it applies anymore as I've mixed-n'-matched parts with other random PSP's.

Philippe said...

I'm using PSP 1004 FAT with 3.71m33-3 + 1.5-2

:p

Eric said...

fat psp (1001) with 3.40 oe-a (may update to m33-3 sooner or later)

Timothée said...

I'm using a PSP 1004 with 3.71 M33-3

VARESANO "mech" said...

Hello,

I'm using:
1 PSP Slim&Lite 3.71 m33-3 (with eLoader for 1.5 homebrews)
1 PSP Fat 3.71 m33-2

Auron said...

im running m33-3 3.71 on the launch psp. im thinking of goin to the latest 3.72 hx-1 but im not sure if the latest update from dax would cause any problems if i installed it :S.

Djip said...

I'm usig a 2 PSP 1004 with 3.52M33-4 & 3.71M33-2+Kernel 1.50v2...
Deadalus PowaAaa...

romain_x_usa said...

PSP 1004 3.52 M33-4
PSP 1004 1.5
PSP 1002 3.72
PSP 2004 3.71 M33-2 + Kernel 1.5 v2

Nice work StrmnNrmn

[X-Us]

stef said...

I'm using PSP 1004 FAT with 3.71m33-3

Mason said...

PSP 1001 NTSC with 3.52m33-4

tioutiou said...

Hello, I have a PSP FAT with firmware 3.40 OE-A (the best for me).

Father StrmnNrmn, please give us a Daedalus R14 who allow to play at zelda ocarina of time with full speed and sound if you can for christmas :-)

Many thanks

anthony said...

PSP FAT
3.71 M33-3
Kernel 1.5v2

wwwyzzerdd said...

Fatty PSP-1001, date code(if it matters) 5B, Firmware 3.52 M33-4 i just upgraded to that not too long ago, after about 2 and a half years of running 1.5, i still use the 1.5 folder, apparently thats pointless, ill try to run the 1.00 build, should work, seeing as everyone here says it does

El Xando said...

PSP-1003 fat with 3.52 M33-4 (may soon upgrade to 3.71 M33-3 with 1.5 kernel or 3.72 HX-1 and use 1.5 hack) and PSP-2003 slim with 3.71 M33-3. Both UK models. I am looking forward to a version of Deadalus for Slim even if the advantages are only small :D

El Xando said...

Also, yes we can use both 1.00 and 1.50 eboots on custom firmware, it's just most people download the KXploited ones for some reason. I have to say I do too, I just don't know why, and I suspect most if not all of the people who downloaded the 1.50 version could of downloaded the 1.00 version.

ptigaetan said...

i have a psp 1004 FAT with 3.71-2 firmware and 1.50 kernel.

michaelp said...

I'm pretty sure it's a fat PSP 1001 or 1000. I got it in Canada.

3.52M33-4.

Lluis said...

I have PSP 1001 FAT with 3.71 m33-3 with kernel 1.5-2.

Thank you for your emulator!!

Tech said...

I've got a PSP 1001 FAT with 3.71m33-3 and 1.50-2

Zak BABAAISSA said...

psp slim psp-2004 avec firmware 3.71M33-3

Robbie said...

I have PSP 1002 fat with firmware 3.52 M33-3.

Bob said...

1.50 original PSP fat. Never upgraded, never will.

PSPMAN90 said...

OOOKay...hehe. Bob... You have problems. Unless u r using your PSP for dev. purposes or you have another PSP with CFW or you don't know that the CFW exist yet. One of those reasons u have for not having a Updated PSP! Well, I have:
PSP TA-82
CFW 3.71M33-3 1.50add-on
(umbricked 3 times)my tird psp in live other 2 echabge and sold.
recovery GUI v3 in VHS
Lots of plugins
there u have it! CFW 3.71M33-2 and 3 are the most used! CFW 3.52M33-4 too! And the New CFW 3.72HX-1 with 1.50 I don't know if any one use it but I didn't put it on my PSP because the apps and homebrews 4 psp aren't the same for it, so the other plugins and Homebrew that are for CFW 3.71M33-3 will not run in HX, or do they?? I mean CFW 3.71M33-3 and CFW 3.72HX-1 are pretty similar. Does they?
Keep thinking on that later!!!
Bye the way I use Daedalus R13 & Daedalus R13% for Kernel 1.50 on my PSP! :) Later!

PSPMAN90 said...

OOOKay...hehe. Bob... You have problems. Unless u r using your PSP for dev. purposes or you have another PSP with CFW or you don't know that the CFW exist yet. One of those reasons u have for not having a Updated PSP! Well, I have:
PSP TA-82
CFW 3.71M33-3 1.50add-on
(umbricked 3 times)my tird psp in live other 2 echabge and sold.
recovery GUI v3 in VHS
Lots of plugins
there u have it! CFW 3.71M33-2 and 3 are the most used! CFW 3.52M33-4 too! And the New CFW 3.72HX-1 with 1.50 I don't know if any one use it but I didn't put it on my PSP because the apps and homebrews 4 psp aren't the same for it, so the other plugins and Homebrew that are for CFW 3.71M33-3 will not run in HX, or do they?? I mean CFW 3.71M33-3 and CFW 3.72HX-1 are pretty similar. Does they?
Keep thinking on that later!!!
Bye the way I use Daedalus R13 & Daedalus R13% for Kernel 1.50 on my PSP! :) Later!

PSPMAN90 said...

soory 4 posting 2x!!! :(

Pac Man said...

3.52m m-33

Mat/Shin said...

slim 3.71-3 ^^
(a friend just bought my 3.71-3 fat and is using Deadalous also)

Christopher said...

I just got a PSP slim, and have 3.71m33-3 on it.

Erik said...

I'm using a PSP 1001 fat with 1.50. So I still use your kxploit versions.

Astanax said...

I'm using a PSP-1001 (Fat) with 3.71-M33-3+ 1.50 addon v2, and Custom Firmware Extender 1.9.2

mrx said...

i use 3.52 M33-4

respect, from ThailanD

RedViper747 said...

PSP FAT
3.03 OE-C

mrtnclzd said...

two fat psps with 3.40oe-a and 1.50 enabled

Oscar said...

PSP 1004 3.72HX-2(Without 1.50 kernel)

frame said...

First of all GREAT JOB. Secondly Please do same things for poor slim&lite owners^^

Thanks a lot. God bless you

Iam using PSp 2001(slim) 3.71 M33-3

Prashant said...

3.71 M33 PSP fat

Richard said...

1 PSP - 3.52M33-4 (PSP-1004)

Runs 1.50 Homebrew, dunno about 1.0

Kyle said...

I'm using a PSP-1001 (TA-082) with 3.71 M33-3 & 1.50 Kernel Subset. I had problems with Mario 64 on the firmware 1.00 version of Daedalus, so I use the 1.50 version.

AndrewCP said...

I'm using a PSP Slim with 3.71 M33-2 firmware and would love to see a Slim version of Daedalus.

rawar said...

PSP Slim 2000 - 3.71-3 M33

You should start a donation to get a PSP slim, I'd donate :). Just an idea.

Juha-Pekka said...

I'm using PSP FAT with 3.52 M33-4, which of course means that the prefered firmware to use is 3.x. 1.5 software works, sort of, just requires reformat, as 1.5 doesn't support memory cards bigger than 4GB (which means, if the software happens to be after 4GB limit, it crashes the system when trying to boot)

I think it would be worth mentioning (also in the release notes) that the 1.0 version works on 3.x kernel (while 1.5 version doesn't)

Rakuen said...

hey this might sound kinda dumb but, can you use an official firmware with daedalus. or can u make it so it'll work. all of my friends have an official firmware psp. is upsetting -_-

-Rakuen

Lachek said...

PSP Slim with 3.60 M33
(not adverse to upgrading CFW, obviously)

Dylan said...
This comment has been removed by the author.
Dylan said...

a)Slim PSP
b)M33 3.71-3
BTW, I don't anyone really uses 1.5 anymore, but I don't really know so I very well could be wrong. Just my two cents

Vinay said...

PSP-2000 (Slim) running 3.71 m33,
and a Japanese PSP-2000 running 3.80.

michniewski said...

I have psp 1.50 firmware.

Ge64 said...

Im using a PSP-2006DR with 3.71M33

Ill gladly help you get a slim, I live in Hong Kong where they are cheap(er)!

SuperSpy said...

Slim with 3.90 M33

Anxiously awaiting daedalus on the slim.

Mitchellja48 said...

PSP slim 2000
3.90 M33

critofer said...

strmnnrmn,
i was just wondering if u could make the daedalus R14 work with version 3.90 version of the psp fat. i am a big fan of nintendo 64, and the classic games, but i cant play them cause i have version 3.90 psp fat.
thanks alot!

Jason said...

I'm running a PSP slim with the 3.90m33-2 firmware.

erik said...

I have a slim with 3.9 m33

PSPMAN90 said...

More reliable CFW:
PSP-1001 TA-86
3.71M33-4 with 1.50 add-on v2
Remote player flashed

Original Large Icons on XBM-Flashed
Mixed- with Original-Simple-XBM
RCO= O,X,[], /\ in colors on accept and decline.
Error sound for interactive action,
Black-line for margin of selection of XBM.
01-02 Dif. Icons
and etc.
Thanks! n_n'!
PSPMAN90